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Area = 15.125 

To find GE command example 
table of values points(xmin,xmax,xstep,f(x),g(x)) points(0,10,1,y(x)) 
derivative function derive(f(x)) derive(y(x)) 
definite integral integral(flower(x),fhigher(x),a,b) integral(0,y(x),−2,2) 
derivate value at a point der(f(x),a) der(y(x),2) 
equation of tangent at a 
point 

tangent(f(x),a) tangent(y(x),2) 

equation of normal at a 
point 

normal(f(x),a) normal(y(x),2) 

x value at first TP: extrx−(f(x),a,b) extrx−(y(x),a,b) 
x value at last TP: extrx+(f(x),a,b) extrx+(y(x),a,b) 
x values list for all TPs: extrx(f(x),a,b) extrx(y(x),a,b) 
y value at min/max: minF, maxF(f(x),a,b) minF, maxF(y(x),a,b) 
when f(x) gives y pointx(f(x),y,a,b) pointx(f(x),y,a,b),  
x at first intersection interx−(f(x),g(x),a,b) interx−(f(x),g(x),a,b) 
x at last intersection interx+(f(x),g(x),a,b) interx+(f(x),g(x),a,b) 
x list all intersections interx(f(x),g(x),a,b) interx(f(x),g(x),a,b) 
nth biggest root: index(pointx(f(x),0,-10,10),n-

1) 
index(pointx(f(x),0,-
10,10),n-1) 

nth biggest TPx: index(extrx(f(x),-10,10),m-1) index(extrx(f(x),-10,10),m-
1) 

nth biggest TPy: f(TPx(n)) f(TPx(n)) 
 



Mathematical expressions 

By Olivier ANSQUER 

All the expressions and calculations in Graphe Easy are written as in a graphic calculator.  

1. Elements of expressions 

a. Numbers 

They are written in the standard way. Use the dot to separate the integer part from the 
decimal part.   

Ex : -1.25, +.25, 123   

A scientific notation is available.   

Ex : 0.000001 = 1e-6, 10 000 000 = 1e7  

b. Operators 

Click here to get the whole operators list.  

c. Standard functions 

They are the functions you can use in all the documents. 
Click here to get the whole standard functions list.  

d. Standard constants 

They are the constants you can use in all the calculations.. 
Click here to get the whole standard constants list.  

e. User's defined functions 

Graphe Easy allows you to define customized functions. 
Click here to know how to create or to modify those functions. You can use them as well as 
the standard functions but do not forget to respect the case of the letters.  

f. User's defined constants 

Graphe Easy allows you to define customized constants. 
Click here to know how to create or to modify those constants. 
To use them, just enter their name but do not forget to respect the case of the letters.  

g. User's defined parameters 

Graphe Easy allows you to define customized parameters. 
Click here to know how to create or to modify those parameters. 
To use them, just enter their name but do not forget to respect the case of the letters.  

h. Variables 

To use the variables, just enter their name. 
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Example : If you enter the equation of a curve as y(x)= f(x), you can use the variable "x" 
in the expression of "f(x)".   

It's impossible to use a variable if a parameter or a constant has the same name. 

2. Examples 

Operators 

By Olivier ANSQUER 

List of available operators 

Here is the list (in priority order) of all available operators you can use in your calculations and 
mathematical expressions :  

Description Mathematical notation Graphe Easy notation

Multiplication A × B A * B

Division
A 

B
A / B

Square A2 A ^ 2 ou A²

Power AB A ^ B

Square root sqrt(A) or rc(A)

One variable function cos x cos(x) or cos x

Several variables function min(2,1,3) min(2,1,3)

Factorial A! fact(A) ou fact A

Product prod(1-x²,3,11)

Sum sum(1-x²,3,11)

Operator Description Example

AND
Test if two expressions are 

different from 0. Useful   to get it 
with the IF function. 

if(x>0 and x<4,1,0) 

OR
Test if one or both expressions 
are different from 0. Useful to 

get it with the IF function. 
if(x<=0 or x>=4,0,1) 

<, <=, <>, =, >=, >
You can compare numbers with 

these operators. It returns 1 
when it is true and 0 else. 

1 < 2, x >= 4, x <> 0 

+ To add two numbers. x + 4, x + -1, 1 + 0 
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Standard functions 

By Olivier ANSQUER 

1. Available helps to use standard functions 

In most cases, when you want to enter or to use a standard function, you can be helped different 
ways :  

a. The whole functions list 

To access the whole functions list easily, just do a right click to display the contextual menu 
and click on the sub-menu "Insert function". 
you will be finding all the functions sorted by categories. If you leave the cursor for a few 
seconds over the name of a function, a brief description appears in a pop-up. If you click on 
the name of a function, its name is pasted and a pop-up is displayed to help you to use this 
function  

b. Get help directly from the name of the function 

If the name of the function is entered, you can select it and press the F1 key : a brief 
description appears in a pop-up. This help is also available by a right-click to display the 
contextual menu followed by a click on "Current selection help".  

2. The whole functions list 

a. Standard category 

- To substract a number from 
another one. x - 4, x - -1, 1 - 0 

* To multiply two numbers. x * 4, x * -1, 1 * 0 

/ To divide a number by another 
one. x / 4, x / -1, 0 / 1 

!
Returns 1 if the number is 0 and 

0 else. Useful to test the 
opposite of a condition. 

!4 = 0, !0 = 1 

%

Returns the rest of a division 
between two integers. If the first 
number is negative, the result is 

negative. 

9 % 4 = 1, 10 % -4 = 2 

^ Power of a number. 2 ^ 4 = 16, 27^(1/3) = 3 

² Square of a number. 2² = 4, 3² = 9 

Name Numbers of 
variables Description Example(s)

Abs 1 Absolute value function Abs(-1.25) = 
1.25, Abs(2) = 2

Returns the smallest number with a 
specified number of decimal greater 

Ceil(-1.256,2) = -
1.25, Ceil
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b. Conversion category 

Ceil 2 than or equal to the specified 
number 

(1.2569,3) = 
1.257

Exp 1 Exponential function exp(0), exp 0.5

Fact 1 Factorial function fact(0) = 1, fact 4 
= 24

Floor 2

Returns the largest number with a 
specified number of decimal less 

than or equal to the specified 
number 

Floor(-1.256,2) = 
-1.26, Floor
(1.2569,3) = 

1.256

Int 1 Integer part function int(1.25) = 1, int 
1.99 = 1

Ki 2

This function can be used only in an 
expression containing a defined 

variable. It returns 1 if the variable 
value is between the two numbers. 

ki(2,4)

Sqrt 1 Square root function sqrt(2), rc 4

Ln 1 Naperian logarithm function ln(1), ln 2

Log 1 Common logarithm function log(1), log 2

Product 3 Product function prod(x²,1,3) = 1² * 
2² * 3²

Rand 1 Random function. Returns a number 
between 0 and the parameter. rand(1), rand 10

Round 2 Returns a number rounded to a 
specified number of decimal places 

Round(-1.256,2) 
= -1.26, Round

(1.2569,3) = 
1.257

Sign 1 Sign function. Returns the sign of a 
number (-1 if it is negative, +1 else). sign(0), sign -1

Sum 1 Sum function sum(x²,1,3) = 1² + 
2² + 3²

Name Number of 
parameters Description Examples

DegToGrad 1
Convert 

degrees to 
grades.

DegToGrad(90), DegToGrad 180

DegToRad 1
Convert 

degrees to 
radians.

DegToRad(90), DegToRad 180

GradToDeg 1
Convert 

grades to 
degrees.

GradToDeg(100), GradToDeg 200

GradToRad 1
Convert 

grades to 
radians.

GradToRad(100), GradToRad 200
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c. Derivative category 

d. Intégration category 

RadToDeg 1
Convert 

radians to 
degrees.

RadToDeg(pi/2), RadToDeg pi

RadToGrad 1
Convert 

radians to 
grades.

RadToGrad(pi/2), RadToGrad pi

Name Number of 
parameters Description Examples

Derive 1

Returns the 
derivative of 

an 
expression

derive(cos(x)+1)

Der 2

Returns the 
derivative 
number of 

an 
expression 
at a point

der(cos(x)+1,2)

Tangent 2

Returns the 
tangent line 
of a curve at 

a point

tangent(cos x,1)

Normal 2

Returns the 
normal 
line of a 

curve at a 
point

normal(cos x,1)

Name Number of 
parameters Description Examples

Integral 4

Calculates the 
integral limited by 

curves of equations 
y=f(x), y=g(x), x=a 

and x=b (cf 
example) 

integral(f(x),g(x),a,b)

integralLR 5

Calculates the 
integral limited by 

the curves of 
equation y=f(x), y=g
(x), x=a and x=b (cf 

example). 
Calculation is done 

with the left 
rectangles method 
with n rectangles. 

integralLR(f(x),g(x),a,b,n)

Calculates the 
integral limited by 
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integralRR 5

the curves of 
equation y=f(x), y=g
(x), x=a and x=b (cf 

example). 
Calculation is done 

with the right 
rectangles method 
with n rectangles. 

integralRR(f(x),g(x),a,b,n)

integralMP 5

Calculates the 
integral limited by 

the curves of 
equation y=f(x), y=g
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the midpoint 

method with n 
rectangles. 

integralMP(x),g(x),a,b,n)

integralT 5

Calculates the 
integral limited by 

the curves of 
equation y=f(x), y=g
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the trapezoid 

method with n 
trapezoids. 

integralT(f(x),g(x),a,b,n)

integralS 5

Calculates the 
integral limited by 

the curves of 
equation y=f(x), y=g
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the Simpson 

rule with  a 
parameter n 

between 1 and 
10000. 

integralS(f(x),g(x),a,b,n)

integralD- 4

Calculates a lower 
value  of the integral 
limited by the curves 
of equation y=0, y=f
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the Darboux's 

rule with n 
rectangles. 

integralD-(f(x),a,b,n)

integralD+ 4

Calculates an upper 
value of the integral 
limited by the curves 
of equation y=0, y=f
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the Darboux's 

rule with n 

integralD+(f(x),a,b,n)
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rectangles. 

area 4

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf example) 

area(f(x),g(x),a,b)

areaLR 5

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf 

example).Calculation 
is done with the left 
rectangles method 
with n rectangles. 

areaLR(f(x),g(x),a,b,n)

areaRR 5

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf example). 

Calculation is done 
with the right 

rectangles method 
with n rectangles. 

areaRR(f(x),g(x),a,b,n)

areaMP 5

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf example). 

Calculation is done 
with the midpoint 

method with n 
rectangles. 

areaMP(f(x),g(x),a,b,n)

areaT 5

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf example). 

Calculation is done 
with the trapezoid 

method with n 
trapezoids. 

areaT(f(x),g(x),a,b,n)

areaS 5

Calculates the area 
limited by the curves 
of equation y=f(x), 

y=g(x), x=a and x=b 
(cf example). 

Calculation is done 
with the Simpson's 

rule with a 
parameter between 

1 and 10000. 

areaS(f(x),g(x),a,b,n)

areaD- 4

Calculates a lower 
value of the area 

limited by the curves 
of equation y=0, y=f
(x), x=a and x=b (cf 

areaD-(f(x),a,b,n)
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e. Search category 

example). 
Calculation is done 
with the Darboux's 

rule with n 
rectangles. 

areaD+ 4

Calculates an upper 
value of the area 

limited by the curves 
of equation y=0, y=f
(x), x=a and x=b (cf 

example). 
Calculation is done 
with the Darboux's 

rule with n 
rectangles. 

areaD+(f(x),a,b,n)

Name Number of 
parameters Description Examples

Infx 3

Returns the 
list of the 
abscissa 

between a 
and b for 
which the 

expression f
(x) admits a 

minimum 

Infx(f(x),a,b)

Infx- 3

Returns the 
smallest 
abscissa 

between a 
and b for 
which the 

expression f
(x) admits a 

minimum 

Infx-(f(x),a,b)

Infx+ 3

Returns the 
biggest 

abscissa 
between a 
and b for 
which the 

expression f
(x)admits a 
minimum 

Infx+(f(x),a,b)

Supx 3

Returns the 
list of the 
abscissa 

between a 
and b for 
which the 

expression f
(x) admits a 
maximum 

Supx(f(x),a,b)
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Supx- 3

Returns the 
smallest 
abscissa 

between a 
and b for 
which the 

expression f
(x) admits a 
maximum 

Supx-(f(x),a,b)

Supx+ 3

Returns the 
biggest 

abcsissa 
between a 
and b for 
which the 

expression f
(x) admits a 
maximum 

Supx+(f(x),a,b)

MinF 3

Returns the 
minimum of 

the 
expression f

(x) on the 
interval [a;b] 

Minf(f(x),a,b)

MaxF 3

Returns the 
maximum of 

the 
expression f

(x) on the 
interval [a;b] 

Maxf(f(x),a,b)

Extrx 3

Returns the 
list of the 
abscissa 

between a 
and b for 
which the 

expression f
(x) admits 

an 
extremum 

Extrx(f(x),a,b)

Extrx- 3

Returns the 
smallest 
abcsissa 

between a 
and b for 
which the 

expression f
(x) admits 

an 
extremum 

Extrx-(f(x),a,b)

Extrx+ 3

Returns the 
biggest 

abcsissa 
between a 
and b for 
which the 

expression f
(x) admits 

Extrx+(f(x),a,b)
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an 
extremum 

Pointx 3

Returns the 
list of the 
abscissa 

between a 
and b for 
which the 

expression f
(x) gives y. 

Pointx(f(x),y,a,b)

Pointx- 3

Returns the 
smallest 
abscissa 

between a 
and b for 
which the 

expression f
(x) gives y 

Pointx-(f(x),y,a,b)

Pointx+ 3

Returns the 
biggest 

abscissa 
between a 
and b for 
which the 

expression f
(x) gives y 

Pointx+(f(x),y,a,b)

Interx 4

Returns the 
list of the 
abscissa 

between a 
and b for 

which f(x)=g
(x) 

Interx(f(x),g(x),a,b)

Interx- 4

Returns the 
smallest 
abscissa 

between a 
and b for 

which f(x)=g
(x) 

Interx-(f(x),g(x),a,b)

Interx+ 4

Returns the 
biggest 

abscissa 
between a 
and b for 

which f(x)=g
(x) 

Interx+(f(x),g(x),a,b)

Intery 4

Returns the 
list of the 

ordinate of 
the 

intersection 
points 

between the 
curves of 

the 
functions f 

Intery(f(x),g(x),a,b)
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f. Statistic category 

g. Trigonometry category 

and g on 
the interval 

[a;b] 

Intery- 4

Returns the 
smallest 

ordinate of 
the 

intersection 
points 

between the 
curves of 

the 
functions f 
and g on 

the interval 
[a;b] 

Intery-(f(x),g(x),a,b)

Intery+ 4

Returns the 
biggest 

ordinate of 
the 

intersection 
points 

between the 
curves of 

the 
functions f 
and g on 

the interval 
[a;b] 

Intery+(f(x),g(x),a,b)

Name Number of 
parameters Description Examples

Min
2 and + or a 

list of 
numbers

Returns the 
minimum of 

a list of 
numbers 

min(2,1,4,3), min(list(2,1,3,4))

Max
2 and + or a 

list of 
numbers

Returns the 
maximum of 

a list of 
numbers 

max(2,1,4,3), max(list(2,1,3,4))

Mean
2 and + or a 

list of 
numbers

Returns the 
mean of a 

list of 
numbers 

Mean(2,1,4,3, Mean(liste(2,1,3,4))

Name Number of 
parameters Description Examples

Cos 1

cosinus 
function 

(parameter 
in radians)

cos(0) = 1, cos(pi/2) = 0
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h. "Other" category 

Sin 1

sinus 
function 

(parameter 
in radians)

sin(0) = 0, sin(pi/2) = 1

Tan 1

tangent 
function 

(parameter 
in radians)

tan(0) = 0

CTan 1 cotangente 
function ctan(2) = -0.457658

ACos 1 arccosinus 
function acos(1) = 0

ASin 1 arcsinus 
function asin(0) = 0

ATan 1 arctangent 
function atan(0) = 0

Cosh or ch 1
hyperbolic 

cosinus 
function

cosh(1) = 1.543081

Sinh or sh 1
hyperbolic 

sinus 
function

sinh(1) = 1.175201

Tanh or th 1
hyperbolic 

tangent 
function

tanh(1) = 0.761594

Name Number of 
parameters Description Examples

If 3

The first parameter is a 
condition 

The second one is the returned 
value if the condition is verified

 

The third one is the returned 
value if else 

if(x>=0 and x<1,1,0)

Simplify 1 Simplifies an expression Simplify(x*x+1-1) = x²

Expand 1 Expands an expression Expand((x-1)²) = x²-2x+1

Solve 2 Isolate a variable (x or y) in a 
relation between x and y 

Solve(1/(x²+1)=1-y,x) 
Solve(1/(x²+1)>1-y,x) 

List 1 and + Creates a list of numbers List(2,1,3,7,4)

Index 2 Returns the nth element in a list 
(the first index is 0)

Index(List(4.1, 2.5, 3.2, 
1.5), 2) = 3.2

Points 2 and +

Calculates one or more lists of 
numbers 

Version 1 : points(list of 
numbers,expr1,expr2...) 

Version 2 : points
(bmin,bmax,step,expr1,expr2...) 

points(supx(cos x,0,20),sin 
x,cos x) 

points(0,10,1,cos x,exp 
x,log x) 
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Standard constants 

By Olivier ANSQUER 

List of standard constants   

Users functions 

Par Olivier ANSQUER 

1. Presentation 

a. Creation/edition 

To display the dialog box to create functions, you can :  

click on Document > New function...  
Display the functions list in the Document bar and click on the top left button or double 
click in a blank part of the list.  

To edit a function, you can :  

In the functions list, click on the name of the one you want to edit and press the space 
key.  
In the functions list, double click on the name of the function you want to edit.  

The options are as follows :  

Name 
The name of a constant has to respect the following rules : 

its name must begin with a letter or underscore  
The other characters must be letters, figures or underscores  
The name can end with one or more 'I  
The name must not be used for another object in the calculator (function, 
constant or parameter)  

Sort 1 Sorts a list of numbers Sort(list(2,1,3,7,4))

Paf 2 Calculate a piecewise affine 
function from points

Paf(list(-2,-1,0,1,2),list(1,-
1,0,2,0))

Tdn 1 Converts a number to decimal 
notation Tdn(3/2) = 1.5

Tfn 1 Converts a number to fractional 
notation Tfn(1.5) = 3/2

Name Description Value

PI ... 3.14159265358979323846 

E ... 2.718281828 

INF
This constant represents an infinite value. It can 

be used as a parameter for the Ki function, to 
indicate an infinite bound. 
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Type 

Simple function : it is a function defined on an interval with a single expression 
with one or more variables.  
Piecewise function : it is a function defined on several intervals with a single 
variable.   

Variables (in the case of a simple function) 
The names of the variables have to be separated by commas. 
The name of each variable has to respect the following rules : 

Its name must begin with a letter or underscore  
The other characters must be letters, figures or underscores  
The name can end with one or more '  
Two variables cannot have the same name   

Expression (in the case of a simple function) 
You have to use the variables declared in "Variables" when you create the function. 
This expression runs every time you use the function and it returns the result.  

Variable (in the case of a function defined on more than one intervals) 
This is the variable of the function. 
The name of the function has to respect the following rules : 

Begin with a character or with an underscore.  
The other characters have to be letters, figures or underscores.  
The name can end with one or more '   

Number of intervals (in the case of a function defined on more than one intervals)  
The number of intervals of the function.  

The table (in the case of a function defined on more than one interval)  
This table allows you to enter the expressions and the bounds of the intervals. 

If you do not want to define a function on one interval, leave a blank cell.   

Description 
This is a description associated with the function. It is displayed in a tooltip when you 
leave the cursor for a few seconds over the name of the function in the list of the 
functions.  

Example 1 
A function called Euro which converts Dollars into Euro. 

Name : Euro 
Type : simple function 
Parameters : Dollars 
Expression : Dollars/1.005 
Description : Conversion function from Dollars to Euros  

Example 2 
A function called U which returns 0 if the parameter is negative and 1 else. 

Name : U 
Type : piecewise function 
Parameter : x 
Number of intervals : 2 
Intervalle 1 : condition : x<0, expression : 0 
Interval 2 : expression : 1 
Description : U function  
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b. Use 

You can use the user's function as the standard functions.  

Examples  

Euro function : Euro 50 ou Euro(100)  
U function : U -1 ou U(1)  

c. Delete 

To delete a function, select it and click on the delete button (the one with a red cross) in the 
button bar at the top of the list. If this function is in use, you cannot delete it and a message 
gives you the list of the objects preventing the deletion. 

2. Default functions 

Default functions are available in every new document. To access those functions, click on "Tools > 
Default functions..." 
You can create or edit those functions like any other user's function.  

User constants 

By Olivier ANSQUER 

1. Presentation 

a. Creation/edition 

To open the dialog box to create a constant you can :  

In the document menu, click on "New constant"  
In the document bar, display the constants list (in the data tab by default) and click on 
the top left button of the list or double click on a blank part of the list.  

To edit a constant, you can :  

Select the constant in the list and press the space key.  
In the constant list, double click on the constant you want to edit.  

When you are editing a constant, you can modify its description only.  

The options of the dialog box for creating or editing constants are :  

Name 
The name of a constant has to respect the following rules : 

Its name must begin with a letter or underscore  
The other characters must be letters, figures or underscores  
The name can end with one or more '  
The name must not be used by another object in the calculator (function, 
constant or parameter)   

Value 
Value of the constant.  

Description 
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It is a description of the constant. It is displayed in a tooltip when you leave the cursor 
a few seconds over the name of the constant. 

b. Use 

When you want to use a constant, just use its name.  

c. Delete 

You cannot delete a constant. You can only cancel its creation with Cancel in the Edition 
menu. 

2. Default constants 

You can use default constants in every new document. You can see the list of the default constants 
in the menu "Tools > Default constants..".. 
These constants can be created or edited like any other constant. If you edit a default constant, you 
can change its name or its value.  

User parameters 

By Olivier ANSQUER 

a. Creation/edition 

To display the parameter creation dialog box, you can :  

Click on "Document > New parameter..."  
In the document bar, display the list of parameters and click on the top left button or double 
click in the blank part of this list.  

To edit an existing parameter, you can :  

Select the parameter in the parameters list of the document bar and press the space key.  
Double click on the parameter name in the parameter list in the document bar.  

The options of the dialog box for creating or editing parameters are :  

Name 
The name of a parameter has to respect the following rules : 

Its name must begin with a letter or underscore  
The other characters must be letters, figures or underscores  
The name can end with one or more '  
The name must not be used for another object in the calculator (function, constant or 
parameter)  

If you cannot change the name of a parameter (grey text), it is because the 
parameter is used by another object.  

Value 
Parameter value.  

Minimum Value  
Minimum value of the parameter. Comment : you can give smaller values in the dynamic 
mode.  

Maximum Value  
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Maximum value of the parameter. Comment : you can give bigger values in the dynamic 
mode.  

Description 
It is a description of the parameter. It is displayed in a tooltip when you leave the cursor for a 
few seconds over the name of the parameter. 

b. Using 

To use a parameter, just enter its name.  

c. Deletion 

To delete a parameter, select it and click on the red cross button in the button bar at the top of the 
list. You cannot delete a parameter if it is used.  

About the graphic interface 

By Olivier ANSQUER 

1. Lists 

You will often find in Graphe Easy lists like this one :   

Every list is made up of a heading with buttons and a list.  

When you leave your cursor over a button of the heading, a tooltip gives you a brief 
description of this button.  

These buttons are : 
The add button 
To create a new element in the list.  
The delete button 
To delete the selected element.  
The up button 
To move up the selected element.  
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The down button 
To move down the selected element.  

In graphic objects lists, moving up or down an object means modifying the order the 
objects are displayed. Graphe Easy displays objects from the top to the bottom.  

Some elements are only present on graphic objects lists : 
Visible symbol 
When it is green, it means that the object is displayed and when it is red, it means the object 
is hidden (but not deleted). If it is a warning, it means the object cannot be displayed (ex : a 
point whose abscissa is 1/a with a=0). Click on the symbol to hide or display the object.  
Expand button 
If you click on this button, you can see more information about the object.  
Options button 
This button displays the properties of the object.  

Double clicking on an element displays its properties 
Double clicking in a blank part of the list creates a new element.  
A right click on a graphic object displays a menu.  

2. Lists of properties 

The lists of properties are very important in Graphe Easy.   

Lists are made up of sections. Every section contains a heading (cf image) and elements. Some 
sections contain a reduction button. You can click on to hide the section (you can also reduce the 
section by double clicking in a blank part of its heading). 
You can press TAB or Shift+TAB to move in the list. 

Many elements can be activated with the SPACE key. 
Tooltips are available when leaving the cursor a few seconds over the elements.  
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3. The document bar 

The Document Bar contains all the data of the active document. Its default aspect is the following::      

But if you tick Tools > Options > Document Bar > "Condensed Document Bar" and if you restart 
Graphe Easy, it looks as follows :      

This presentation makes the parameters, constants and functions lists more accessible. 
In Tools > Options > Document Bar, you can also choose the tabs you want to display.  

4. Personalisation 

You can customize the graphics interface of Graphe Easy. In Display > Customize..., the dialog box 
displays the following tabs :  

Commands : you can drag and drop the elements to the menus or to the toolbar of Graphe 
Easy.  
Toolbars : to create and manage the toolbars.  
Tools : to manage the elements of the tools menu.  
Keyboard : to manage hotkeys.  
Menu : to manage the menus of Graphe Easy.  
Options : a few options to manage the graphic interface.  

5. Back-up/recovery 

In Display > Interfaces, you can save the whole aspect of the graphic interface. 
To get it back later, just go to Display > Interfaces and click on the name of your saved interface.  

Customize the interface 

By Laurent HIVON 

1. Presentation 

Graphe Easy allows you to create and use several interfaces simultaneously.  

For example, you can create a simple interface for your pupils with only one toolbar which 
contains all the tools they have to use.  

An interface is made of : 

Customized toolbars and menus.  
The layout of the tool bars on the screen.  
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Locked or unlocked access to features.  

Every interface is saved as a its-name.reg file.  

If you want to know where this file is, just do a click on Tools > Options > Folders.  

To copy interfaces from a PC to another one 

To export interfaces from a PC : 

Click on Display > Interfaces > Options > Export...  
Choose the folder you want to save the interface in.  
Click on "OK".  

To import interfaces on a PC : 

Click on Display > Interfaces > Options > Import...  
Choose the folder containing the interfaces you want to import.  
Click on "OK".  

2. To create a new interface 

a. Toolbar and menus creation/modification 

1. Click on Tools > Customize.  
2. To modify a Toolbar, display it and follow steps 6 and 7.  
3. Click on Toolbar > New.  
4. Name the new toolbar then click on "OK". A new empty toolbar is displayed, even if it 

may be hidden behind the active dialog box.  
5. Click on the Commands tab.  
6. Select the categories one by one, and for each, drag and drop the icon you want into 

your new toolbar. You can sort the icons of the toolbar whenever you want.  
7. Click on "Close" when it is finished.  

b. How to rearrange the toolbars in the window of Graphe Easy 

You just have to move the toolbars wherever you want.  

c. To choose lock options 

Click on Tools > Lock...  
Select the lock options you want to activate.  
Choose a password (optional) and click on "OK".  
Click on "OK".  

d. To save the new interface 

Click on Display > Interfaces > Create/Modify...  
Choose the name of your new/modified interface.  
Click on "OK".  

e. To customize the use of this new interface 

You can choose an interface at the start up of Graphe Easy : 

Click on Display > Interfaces > Options.  

Page 20 of 41Mathematical expressions

26/06/2008file://C:\Documents and Settings\Owner\Local Settings\Temp\~hh9558.htm

file://C:Documents


Tick "Choosing an interface at the start-up".  

To choose a default interface : 

Click on Display > Interfaces > Options.  
Select "Default Interface".  

3. To add new tools 

You can run external applications, directly from Graphe Easy. For example, if you want to run 
WordPad :  

Click on Tools > Customize.  

Click on the Tools tab an then on .  
Enter "WordPad" in the text zone.  

Click on  and look for the wordpad.exe file.  
Click on "Close".  

Mathematical objects 

By Olivier ANSQUER 

What is called a mathematical object is a curve, integral, inequation, scatter plot, sequence...  

1. Creation 

There are different ways to create a mathematical object :  

From the Menu bar : 
Click on "Document > New mathematical object" and then : 

Select " Choice of the type..." to display a dialog box to choose the mathematical 
object type you want to create.  
Click on "Ditto" to create an object of the same type as the last created.  
Select a type in one of the sub-menus.   

From the Document bar 

Displayed on the left of the screen, it contains all the objects of the document. 
If it is not displayed, click on "View > Document bar".  

In the "mathematical objects" list (first tab on the left), add a new object (see graphic 
interface to get more information about creating elements in a list).  

If you use one of the ways mentioned above in which the object type is not given, a dialog box is 
displayed to allow you to choose the type of the mathematical object you want to create. 
In the left list, click on the category you want, and double-click on the object (or click on the object 
and click on the next button) on the right side of the dialog box.  

A dialog box is displayed to edit the properties of the object (see the graphic interface page).  

Example  

Create a curve of the equation y = cos x  

1. Click on "Document > New mathematical object > Choice of the type..".  
2. Click on "Basic Types" and on "Curves of the equation y = f(x)" to select it and click on 

the next button.  
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3. In the properties screen, the default name "y" is ok. Just enter the expression "cos x".  
4. Click on end.   

2. Edition 

To edit one of the mathematical objects in the "mathematical objects" list from the document bar, 
you can :  

Double-click on the name of this object.  
Do a right click on the object and select "Properties..." in the contextual menu.  

If an object is already used by another one, several properties may be unavailable. 
Ex : You create "y1(x)=cos(x)" and "y2(x)=y1(x+1)". When you edit "y1(x)=cos(x)", you 
cannot change its name because it is used by "y2(x)=y1(x+1)".  

3. Results 

With some objets, you can display results. To do it, do a right click on the object and select 
"Results..." in the menu.  

4. Deletion 

To delete a mathematical object, select it in the "mathematical objects" list of the document bar and 
click on the "Delete" button (see the graphic interface page for further information).  

Of course, you cannot delete an object if it is still used by another one.  

5. Definitions 

Statistic definitions. 

6. Further information about properties and mathematical objects 

a. Implicit curves (f(x,y)=0) 

When you create an implicit curve, xmin, xmax, ymin and ymax are the one of the active 
view. After the creation of the object, if you want to recalculate the curve with the limits of the 
actual view, do a right click on the object and select "Recalculate..." in the menu.  

b. Discontituity limit 

This property is available for most of all the y = f(x) or x = f(y) curves. The attempted value 
has to be between 0 and 100. 
It represents a limit. Below this limit, Graphe Easy considers there is a discontinuity in the 
curve. 

For a y=f(x) curve  

The view height is n pixels and discontinuity limit is l. 
If two points of the curve are far from more than (l*n)/100 pixels in ordinate they will not 
be connected.   

When you do not want to connect connected points, choose a bigger discontinuity 
limit. 
When you  want to connect disconnected points, choose a smaller discontinuity 
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limit.  

Example 1 : f(x) = int(cos(x))+0.5 

With a very big discontinuity limit, there is no discontinuity :  

When the discontinuity limit is smaller (0 is ok in this case), we can have this :    

Example 2 : f(x) = x^3-2x+1 

With a very small discontinuity limit, the curve is not drawn where its slopes 
are very big :  

With a bigger discontinuity limit (100 is OK in this case), we can have this :    

c. Affect real coordinates to points 

To get a better drawing, you had better tick this box. If the object is made up of 
horizontal/vertical lines, do not tick this box to avoid a blurred drawing.  
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Statistic definitions 

By Laurent HIVON 

1. Discrete data 

Here are the definitions used in Graphe Easy for discrete data :  

2. Continuous data 

Here are the definitions used in Graphe Easy for continuous data :  

3. Time series 

Graphe Easy uses multiplication to treat time series. Starting with Y data given by the user :  
Graphe Easy smoothes data with the moving average rule. It gives new data Y'.  
Graphe Easy applies the least squares approximation to the Y' data. It gives T data.  
Graphe Easy calculates S=Y/T.  
Then, Graphe Easy calculates the base series Sx with the corresponding S values using 
arithmetic mean.  

Graphic objects 

By Olivier ANSQUER 

Graphic objects allow you to illustrate and comment your curves. There are plenty of them : lines, 
rectangles, images, labels....  

Word Definition

First centile The smallest value below which 1% of the population lie. 

First decile The smallest value below which 10% of the population lie. 

First quartile The smallest value below which 25% of the population lie. 

Median The middle term, or, if there is an even number, the average of the two middle 
terms when the values are written out in ascending order. 

Third quartile The smallest value below which 75% of the population lie. 

Ninth decile The smallest value below which 90% of the population lie. 

99° centile The smallest value below which 99% of the population lie. 

Word Definition

First centile The smallest value below which 1% of the population lie. 

First decile The smallest value below which 10% of the population lie. 

First quartile The smallest value below which 25% of the population lie. 

Median The smallest value below which 50% of the population lie. 

Third quartile The smallest value below which 75% of the population lie. 

Ninth decile The smallest value below which 90% of the population lie. 

99° centile The smallest value below which 99% of the population lie. 
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1. Creation 

First, you have to choose the type of the object you want to create. So you can :  
Click on " Document", and select an element in one of the submenu 'Lines', 'Basic forms', 
'Arrows' or 'Texts and balloons'.  
In the drawing toolbar, click on  and select an element in the menu.   

Once you have selected the type of the object, draw a rectangle in the view with the mouse 
(comment : for the balloons there is one more step but it is very easy to understand how it works). If 
the rectangle is just a point, no object will be created. 

When the object is created, it is in the list of all the objects in the document bar.  

2. Edition 

To edit a graphic object, be sure no tool is selected (press Escape).  
You can move the graphic object with your mouse. To resize it, click on it and move the handles. 
To edit the object properties, double click on it or on the name of the object in the list of all the 
objects in the document bar.  

3. Position 

You can position a graphic object different ways depending on its type :  

Standard Position 
Available for all the "rectangular" objects. Enter the abscissa of the right and the left side and 
enter the ordinate of the upper and the lower side.   

Position with anchorage 
Available for all the "rectangular objects". Enter the coordinates of the anchorage point  and 
the pixel size of the object. This kind of position is well adapted to the texts because the 
position does not change even if you are zooming or moving the view.   

Fixed position in the view 
Available for all the "rectangular" objects. For every side, enter the position depending on the 
view.   

Fixed position in the view with anchorage 
Available for all the "rectangular" objects. Enter the position of the anchorage point (depends 
on the view) and enter the pixel size of the object. This type of position is well adapted to 
texts because the size does not change even if you are zooming or moving the view.   

Points 1 et 2 anchored 
Available for all the "lines" objects. Enter the coordinates of the two extremities of the line.   

Point 1 anchored 
Available for all the "lines" objects. Enter the coordinates of an extremity and enter the 
distance ( in pixels) between the two extremities.   

Position of balloons and labels 
These objects are designed to point out an object. You can write a text in them. Enter the 
coordinates of one point and the position of the "rectangular" zone ( which can be a text 
zone ). 
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The distance between these two parts that you have to enter in the object properties is 
represented in the upper drawing as  x1 and y1. 
The size of the text zone that you have to enter in the object properties is represented in the 
upper drawing as x2 and y2.  

4. Texts 

You can associate a comment to any graphic object. To do it, just tick "Text" in the "Displayed 
elements" section. Enter the text in the "Text" section.  

If the type of a graphic object is always used to display texts :  
Tick "Text" in the "Displayed elements" section of this type of object,  
Do a right click on the object and select " Set up as default properties".  

Now, every time you will be creating this type of object a dialog box allows you to enter 
your text.  

Graphe Easy allows you to create dynamic texts. These texts are containing zones between (* and 
*). The text displayed in these zones contains the result of the calculation made by the Graphe 
Easy calculator :  

Examples   

1. Simple calculation : 
Entered text : This is the result : (*1/2+2*) 
Displayed text : This is the result : 5/2   

2. Parameter value display : 
Entered text : ParameterName = (*ParameterName*) 
Displayed Text : ParameterName = 2.3   

3. Integral value display : 
Entered text : I = (*Integral(0,x²,1,5)*) 
Displayed text : I = 41.33333  

Move in a view 

By Olivier ANSQUER 

To modify the view, use the tools available in the Zoom menu and in the toolbar "Zoom and Move 
functions". This page explains how to use the main tools of this category.  

1. Window range 
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This displays a dialog box allowing you to enter the boundaries of the visible zone. To be used 
when you want to enter very precise limits.  

2. Zoom +/- 

Select this command and : 
Do a left click if you want to zoom-in x2 and centre the view where you have clicked.  
Do a right click if you want to zoom-out x2 and centre the view where you have clicked.  

3. Dynamic Zoom 

Select the command, press the left button of the mouse and : 
Move to the top to zoom in.  
Move to the bottom to zoom out.  

While "Dynamic zoom" is selected, pressing the "Ctrl" key gets you to "Dynamic move".  

4. Zoom box 

Select the command, draw a rectangle on the view to zoom on this selected area.  

5. Centre the view 

Select the command and click in the view to centre where you have clicked.  

6. Dynamic move 

Select the command, press the left button and move your mouse.  

While "Dynamic move" is selected, pressing the "Ctrl" key gets you to "Dynamic zoom".  

7. Adjust horizontally/vertically 

Adjust the selected axis to get an orthonormal basis.  

8. Strech/shrink horizontally 

Double or reduce by half the view of the units on the x-axis.  

9. Strech/shrink vertically 

Double or reduce by half the view of the units on the y-axis.  

The wheel of the mouse allows you to zoom on the view. 
Leave the middle button of the mouse pressed allows you to move the view.  

Dynamic mode 

By Olivier ANSQUER 

1. What is it ? 

The dynamic mode makes you see the influence of a parameter variation on your graphs. You 
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make your parameter change step by step. You can create animations too.  

2. Using 

a. Prepare the document 

In all cases, your document must contain a parameter if you want to use the Dynamic mode 
(about parameters).  

b. Run the dynamic mode 

First, display the dialog box to manage the dynamic mode : click on "Display > Dynamic 
mode dialog box". 
Then click on the down left button (dynamic mode range). you can choose the dynamic 
parameter, its bounds and its step.  

If you enter minimum and maximum values in the parameter properties, these 
values will be applied as default values in the dynamic mode.  

In the options section, you can set the speed of the parameter variations and the value of the 
parameter when you stop the dynamic mode. 
To activate the dynamic mode, click on the red exclamation mark.  

c. Using the dynamic mode 

You can use it from the dynamic mode dialog box. The nine central buttons are associated to 
a hot key (see the pop-up menu on each button).  
To leave the dynamic mode, click on the "Square" button. 
The "Floppy disk" button allows you to save the images sequence as a file sequence or as 
an animated gif.  

The calculator 

By Olivier ANSQUER 

1. Introduction 

The calculator is displayed in the bottom left part of the screen. 
If it is not, just click on "Display > Calculator".  

The results of the calculations are displayed when you press the Enter key. That's all ! To go 
further :  

A right click displays a contextual menu which allows you, among other things, to insert 
functions.   

The Up and Down keys allow you to edit the previous calculation.   

The F2 key clears the screen of the calculator.   

If you select a function or a constant and if you press the F1 key, a help window appears in a 
pop-up menu.  

2. Examples 

a. Calculates a derivative 
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Use the Derive function.  

Ex : Derivative of x²+3x-1.  

> Derive(x²+3x-1) 
2x+3 

b. Find the equation of a tangent 

Use the Tangent function.  

Ex : Find the equation of the tangent of y = cos x at x=2.  

> Tangent(cos x,2) 
-0.9092974*x+1.402448 

c. Find the extremums of a function 

Use the extrx, extrx- or extrx+ functions. 
if you only want the maximums, use the supx, supx- or supx+ functions. 
That is the same for the minimums with the infx, infx- or infx+ functions.  

Ex : Find the extremums of y = cos x on [0,10].   

> Extrx(cos x,0,10) 
{ 0 ; 3.141593 ; 6.283185 ; 9.424778 }   

Ex : Find the first minimum of y = cos x on [0,10].   

> Infx-(cos x,0,10) 
3.141593  

Ex : Find the last maximum of y = cos x on [0,10].   

> Supx+(cos x,0,10) 
6.283185 

d. Find a point of a curve 

Use the Pointx, Pointx- or Pointx+ functions.  

Ex : Find the points of the curve of equation y = cos x on [0,10] with an ordinate 0.5.   

> Pointx(cos x,0.5,0,10) 
{ 1.047198 ; 5.235988 ; 7.330383 }   

Ex : Find the first point of the curve of equation y = cos x on the interval [0,10] with an 
ordinate 0.5.   

> Pointx-(cos x,0.5,0,10) 
1.047198 

e. Find the intersections of  two curves 

use the Interx, Interx- or Interx+ functions. 
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Ex : Find the intersections of y = cos x and y = sin x on [0,10].   

> Interx(cos x,sin x,0,10) 
{ 0.7853982 ; 3.926991 ; 7.068583 }   

Ex : Find the first intersection of y = cos x and y = sin x on [0,10].   

> Interx-(cos x,sin x,0,10) 
0.7853982 

f. Calculates point series 

Use the Points function.  

Ex : Calculates the values of exp x and ln x when varying x from 0 to 5 with a step of 1.  

> Points(0,5,1,exp x,ln x)   

Ex : Calculates the values of y = cos x for its extremums on [0,10].  

> Points(extrx(cos x,0,10),cos x) 

x exp(x) ln(x)

0 1 ndef

1 2.718282 0

2 7.389056 0.6931472

3 20.08554 1.098612

4 54.59815 1.386294

5 148.4132 1.609438

x cos(x)

0 1

3.141593 -1

6.283185 1

9.424778 -1

Examples 

By Olivier ANSQUER 

Some examples are delivered with Graphe Easy to illustrate its possibilities. To see them, 
you just have to click on "File > Samples". 
In the opening dialog box, samples are in the selected default directory. You can choose the 
one you want by browsing in the sub-directories.  

View properties 

By Olivier ANSQUER 

1. How to display it 
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A few methods are available : 
click right on the view and select "View properties...".  
Select "View > Properties".  
In the list of all the objects in the document bar, edit "Axis and grids".  

2. Presentation 

The view properties allow you to set very precisely the aspect of your graph and its 
printing. The tabs are :  

a. "General" tab 

This allows you to set the window, the background and the type of graph. You 
can also choose a fixed ratio between the x-axis and the y-axis when they are 
linear ones.  

Do not set a transparent background ! The results would be 
strange ;=) As there is nothing behind the background there is no 
need to set the background transparent.  

b. "x-axis" tab 

This tab allows you to set the aspect of the x-axis and its scale.  
The "Properties" section allows you to set the displayed elements (scales, 
labels...) and to set how the elements are displayed.  

The "Main graduation size" means the length of the segments on 
each graduation. The unit is the pixel.  

The "Scale" section allows you to choose between a linear and a logarithmic 
scale. 
In the case of a linear scale, you can choose the origin of the axis and a way of 
graduation. 
In the case of a logarithmic scale, you can choose a way of graduation and a 
format for the numbers. 

c. "y-axis" tab 

This tab allows you to set the aspect of the y-axis and its scale.  
The options are the same as the "x-axis" tab.  

d. "Font" tab 

This tab allows you to choose the fonts used for graduations and axis labels.  

e. "Grids" tab 

This tab allows you to set different grids : vertical, horizontal, radial and polar 
grids.  

f. "Print" tab 

In this tab you will find all the settings about printing the graphs.  
The first section is about the "Image position". You can set the position of the 
image on the page. Sometimes you have to give an anchor point which is used 
when the image is too large for the page.  
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Example about the use of an anchor point.  

You chose to print at a fixed scale (1 cm for 1 unit). Imagine your x-axis is 
from -10 to 10. So you need a 20 cm width page. If your page is only a 15 
cm width one, you have to reduce your x-axis from 20 units to 15 units. 
If the anchor point is on the left, you will print from -10 to 5 only.  
If it is centered you will print from -7.5 to 7.5 and if it is on the right, you will 
print from -5 to 10.   

In the "other elements" section, you can choose a title and a border. 
In the "Options" section, the "print object sizes" element allows you to set the 
size of objects whose size is in pixels. 

Animations 

By Olivier ANSQUER 

1. Presentation 

Graphe Easy allows you to save sequences of actions you can execute later. These 
sequences are called "Animations". They can help you to illustrate the construction of 
a graph. 
In the document bar, the last tab contains the list of the existing animations. In this 
tab, you can see different buttons.  
Four on the left :  

The first one allows you to create a new animation.  
The second one allows you to modify the current animation (the one selected in 
the list under the buttons).  
The third one allows you to save the current animation in different files formats 
(bitmap, metafile or animated gif).  
The fourth one allows you to delete the currrent animation.  

Four buttons on the right allow you to play the current animation : 
The first one allows you to stop the current animation.  
The second one allows you to play one stage of the current animation only.  
The third one allows you to play or to pause the current animation.  
The fourth one allows you to play the animation faster..  

These four actions can be executed from the View > Current Animation 
menu where you can use hotkeys (F9 to F12 by default) also.  

2. Creation/edition 

When you create or modify an animation, the dialog box contains a zone to enter the 
name of the animation and another one to display the list of the stages of this 
animation. 
All the stages are played in the order in which they are numbered.You can add, delete 
or modify stages.  

3. What kind of stages are available ? 

Most do not need any explanation because they just play automatically basic actions. 
Here is some informations about some of them :  

a. Load object state 

If you do a right click on an object name (in the picture, in the "mathematical 
objects" list or in the "All objects" list) you can click on "Save state..." in the 
menu and save its current properties under a new name. These states can be 
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reloaded in this menu by "List of the object states". 
This kind of Stage allows you to do exactly the same. You just have to choose 
the object and load its state. 
What is the use of it ? To change the color of a curve, to change the position of 
a text...  

b. Display animation comment 

The "Animation" tab contains a comment zone. This kind of state allows you to 
update the displayed text.  

c. Modify displayed area 

This action allows you to zoom on a zone of the picture. If you want the zoom 
to be instantaneous (without any transition), just set up time duration on 0 ms.  

d. Go to stage n 

Stages are executed in the order in wich they are numbered and the animation 
is finished when the last stage has been played. This kind of stage allows you 
to go to a precise stage. You just have to indicate its number. The condition is 
an expression which is calculated when the stage is executed. If the value is 
not 0, you jump to the designed stages else the animation plays the next stage.  

e. Pause 

The animation is paused. The user must click again to go on.  

f. Play animation 

An animation can contain another one.  

If you want to play an animation inside another one you just have to 
put a _ before its name. This one will be displayed apart in the list of 
animations. It is only to make the difference between the animations 
and the "sub-animations" which are only animations called by 
others.  

It can be useful when, in an animation, you play the same action several times. 
In this case, you create an animation cantaining these actions and you call this 
animation every time you need it. 

Do not hesitate to use this possibility ! If you name your "sub-
animation" with an explicit word, your animation will be easier to 
understand than without it.  

Formula editor 

By Olivier ANSQUER 

1. What is it ? 

It is an editor which allows you to create and modify mathematical formulas. 
These formulas can be inserted in the picture.  

2. How to run it ? 
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a. To illustrate your picture 

Mathematical formulas are quite the same as the other graphic objects 
(see the graphic objects page). Just do a double-click on the object or 
make a right-click on it and select "Formula editor..." in the contextual 
menu.  

b. Wysiwyg interface 

If you prefer to enter your mathematical expressions with the "wysiwyg" 
editor instead of doing it as plain text, you can make a right-click in the 
text zone and select "Formula editor..." in the contextual menu.  

3. Using 

The editor is made up of with the following elements :  

a. A menu 

It is at the top of the screen and it allows you to save or open "formulas" 
files and to export them to a file or to the clipboard. 
You can access the Windows character map.  

If square roots don't print correctly on your computer, in 
Options, check the available option.  

b. A vertical toolbar 

These buttons allow you to do the basic actions on formulas (copy and 
paste, cancel actions...). The second button (the pen) allows you to 
import a valid Graphe Easy expression into the formula.  

Example  

Enter the variable "x" and the expression "sqrt((x+2)/3)". 
Notice that if the editor is displayed as Wysiwyg, you cannot choose 
the variables.  

c. A horizontal toolbar 

These buttons allow you to enter the elements of your mathematical 
formula. To place an element in the formula, just select it. It is applied to 
the current element.  

Examples  

If you insert the "square root" element while "x+2" is selected you will 
obtain the square root of "x+2". 
If you insert pi while "x+2" is selected, "x+2" is replaced by "pi".  

d. A rectangular zone in which the formula is displayed 

This zone contains the formula and allows you to select its different 
elements. You can drag and drop elements. The arrows of the keyboard 
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allow you to browse in the formula :  
Left and right keys allow you to move in the same level of the 
formula.  
Up and Down keys allow you to accesse to an upper or lower 
level of the formula.  

Example  

The formula is "x+2" and "x" is selected. 
The left and right keys allow you to move from "x" to "2" and return 
("x" and "2" have the same parent : their sum). 
The up arrow key allows you to move up and select the "parent" of 
"x"  which is the sum "x+2". 
The down arrow key allows you to move down and select the first 
"son" of the sum : "x".  

The contextual menu of this zone allows you to :  
Modify colors, styles and fonts.  
Modify the size of the current element.  
Expand or simplify the current element if it corresponds to a valid 
Graphe Easy expression.  

View styles 

By Olivier ANSQUER 

1. Presentation 

A view style contains all the view properties. These styles allow users to 
save and easily get view properties often used.  

2. Creation 

It is very simple. Set the view properties, do a right click on the view and 
click on "Create a style out of the view...". The style editor opens and 
you just have to choose a name for this new style.  

3. The style editor 

The style editor is a dialog box which allows you to create styles. You 
can display it : 

By a right click in the view and a click on "Style editor...".  
By clicking on View > Style Editor.  

The style editor displays all the available styles. You can modify them by 
clicking on "Properties" or you can apply one of them to the current view 
by clicking on "Apply to the current view". In the "Default" list you can 
choose a style which will be applied to any new view. 

4. Copy a style to another computer 

To copy a style to another computer, you just have to :  
1. Click on "Tools > Options".  
2. Click on the "Directories" tab and remember the name of the 

Interface style directory.  
3. Go to this directory and copy the file corresponding to the style 

you want.  
4. Paste this file in the equivalent directory of the other computer.  
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Comments 

By Olivier ANSQUER 

1. Presentation 

You can associate a comment to any document in Graphe Easy. This 
comment is in the comment tab of the Document bar.  

When there is no comment, a help text is displayed.  

This comment can be used to describe the graph or to explain how to 
work with the graph (for example how to use the dynamic mode). 

2. Edition 

You can create or modify a comment by clicking on "Document > 
Comment....". If you want to change the font, you can create your 
comment in WordPad and paste it in Graphe Easy.  

You can change the default background colour by clicking on 
"Tools > Options...".  

Drawing images 

By Olivier ANSQUER 

1. Principle 

Here is some information to understand how Graphe Easy manages 
images and to know how to use it :  

a. Available libraries 

Graphe Easy can draw images with two different "libraries". A 
library is a set of computing functions which allow you to draw 
images. Choosing a library influences the speed of drawing, its 
quality and the possibilities. The two libraries are : 

GDI 

Rather quick but :  
You cannot insert images (replaced by a crossed 
out rectangle)  
You cannot display gradients (replaced by a plain 
colour)  
You cannot display texts on line objects  
You cannot display some tranparency effects  
A few patterns cannot be displayed (replaced by a 
plain colour)  

Using GDI library allows you to see your images quickly. 

GDI+ 

It's slower than GDI. It allows you to draw all the elements 
of your image and manages transparency. It can also 
smooth the objects and is more precise than GDI. 
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b. Rendering quality 

Rendering quality influences drawing quality (shades, texts and 
smoothing for examples), number of points calculated to draw 
curves and the way grids are displayed.  
Available values to manage the rendering quality are from "very 
low" to "the best". Your choice depends on the relationship 
between the speed and the quality you want.  

c. Different cases 

Graphe Easy is parametrized to draw in different situations. 
These situations are called cases. For example : print, print 
preview, object edition , view edition ...  

d. Final rendering 

The final rendering is a drawing operation which is done at the 
end of an action ( zooming, moving an object...). 
For example, during the moving of an object we want to have an 
instant reaction. So, for the " Object edition" case we must 
parametrize the current library and rendering quality to get a fast 
drawing.  

What happens when the drawing is finished ?  

By this time, the "Final pre-rendering" is used to draw the view 
again. Next if the "Automatic rendering" is activated, the view is 
drawn using the "Automatic final rendering" case.  

The Automatic final rendering runs as a background 
job so you still can move the object again. You can 
see the progress of the final rendering in the state bar.  

Another final rendering case exists : the "Manual final rendering" 
that you can run by yourself.  

The cases associated to the final rendering are 
different for the normal mode and for the dynamic 
mode.  

2. Parametrization 

a. Where can I parametrize ? 

Click on "Tools > Rendering Options...". The displayed dialog box 
allows you to set : 

Automatic rendering activation.  
The library and the rendering quality associated to every 
case.  

The default settings allow you to obtain top quality prints and 
exports, fast editions with GDI and a high quality final rendering 
with GDI+. Note that the manual final rendering is better than the 
automatic one. 

b. Advices 
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To get the best results, use the same quality for "Final pre-
rendering" and for "Automatic final rendering".  
If "Automatic rendering" is set as "Final pre-rendering", the 
"Automatic rendering" will never run.  
The Standard toolbar contains a button to activate or 
deactivate the automatic rendering (default hot-key : press 
the A key) and a button to run the manual final rendering 
(default hot key : press the R key). Remember to use 
them.  
If your graphs contain images that you want to be 
displayed all the time, use GDI+ for all the available cases.  

Lock objects 

By Olivier ANSQUER 

1. Presentation 

You can lock : 
the objects of the "mathematical objects" list in the document bar.  
the objects of the "all objects" list in the document bar (except 
"Axis and Grids" and ""Mathematical objects" List").  

Locking an object protect its edition and hides its name and definition. It 
can be interesting to hide the equation of a curve. 

2. Add/delete 

To lock an element, just do a right click on its name and click on "Add 
protection" in the contextual menu. Choose the new displayed label and 
a password. When an object is protected, you have to enter the 
password if you want to edit it. 
To delete the protection, do a right click on its name, click on "Delete 
protection" in the contextual menu and enter the password.  

Protect Graphe Easy 

By Olivier ANSQUER 

1. Why ? 

When many people can use Graphe Easy on the same computer (for 
example pupils in a school), it may be interesting to protect or to forbid 
functions or possibilities (especially the graphic interface ones) if you 
want to keep a certain configuration.  

Example   

You have created default constants and functions and you often use 
them. 
You want to use them a few days later but someone has  : 

Deleted your constants and functions.  
Moved the toolbars.  

It could be annoying... 

Protect Graphe Easy can be useful when you want all the computers in 
a room to be configured in the same way. 

2. How ? 
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Click on Tools > Lock...". If you are asked for a password, it is the one 
you entered when installing Graphe Easy (except if you entered another 
one in this dialog box). 
You can protect a few actions with a password :  

Access to ...  
You can protect most parameters of the Graphe Easy interface.  
Loading an interface (Display menu)  
It will no longer be possible to load another interface by clicking 
on Display > Interfaces .  
Creation/modification of an interface (Display menu)  
It will no longer be possible to create/modify/delete interfaces 
styles by clicking on Display > Interfaces.  
Choose a default interface (Display menu)  
It will no longer be possible to choose an interface style by 
clicking on Display > Interfaces.  
Modify view styles  
The view styles will no longer be available in Tools > Styles 
editor.  
Modify objects' default attributes  
Modifying objects' default attributes affects the new objects of this 
type.   

The "Password..." button which is down the page allows you to enter the 
password required when you want to access all the protected actions. 

If the computer is used by many people you had better 
enter a password. 
If someone else does it before, you cannot access all the 
functions of Graphe Easy !  

Import and export files 

By Laurent HIVON 

1. Export graphic files 

Graphe Easy saves all files with the extension gef. But you can save 
them as a bitmap or as a metafile. To do it :  

Do a right click on the view  
Select "Export...".  
Choose the folder, the name of the file, its format and click on 
OK.  

2. Import images 

You can insert images in a picture. To do it :  

Click on Document > Basic Forms > Image.  
With the mouse, draw a rectangle on the picture.  
Do a double-click on the displayed image.  
Do a double-click on the displayed image once again.  
Select the image file you want to insert.  
Click on OK.  
Click on OK again.  

If you want to put an image as a background of your picture :  

Do a right click in your picture.  
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Click on View properties > General > Background > Type > 
Image.  
Click on Background > Properties > Select image.  
Select your image and click on OK.  

3. Export a Mathematical Formula 

Graphe Easy allows you to export a mathematical formula written with 
the editor to paste it in another document :  

Click on Document > Texts and balloons > Mathematical formula.  
Create your formula.  
To copy it to the clipboard : 

Click on Copy.  
Select the format you want.  

To save it in a file : 
Click on Export.  
Choose the folder.  
Choose the name of the file.  
Click on Save.  

4. Export and import an interface  

Graphe Easy allows you to export interfaces from a PC :  

Click on Display > Interfaces > Options > Export...  
Choose the folder where you want to save your interfaces.  
Click on OK.  

Graphe Easy allows you to import saved interfaces :  

Click on Display > Interfaces > Options > Import...  
Choose the folder containig the interfaces.  
Click on OK.  

5. Import and export data 

a. Import data 

Some mathematical objects need to enter many data (Lagrange's 
polynom, Hermite's polynom, statistics...). If this data is in another 
document - in a spreadsheet for example-, you can import it. 
There are two ways to do it :  

Import data from a text file 

Many applications allow you to export data as a .txt file.  

In your application, save your data as a .txt file.  
In Graphe Easy, do a right click in a cell of the list of 
points.  
Click on Import.  
Select the .txt file and click on OK.  

Import data with a "Copy and Paste" 

In the document containing your data, select it and copy it 
to the clipboard.  
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In Graphe Easy, do a right click in one of the cells of the 
list of points.  
Click on "Paste list". The size of the list changes 
automatically and the content is pasted.  

By default, when you are importing data, commas are 
replaced by dots. If you want to de-activate this 
procedure, just do it in Tools > Options.  

b. Export data 

Graphe Easy allows you to export data charts as a .txt file :  

In Graphe Easy, do a right click in a cell on a list of points.  
Click on Export.  
Select the folder you want to save your file in.  
Enter the name of your file, click on Save.  

6. Export an animation 

Graphe Easy allows you to save an animation in different graphic file 
formats :  

Load the animation.  
In the Document bar, click on the Animations tab  
Click on .  
Select the file format you want to export your animation in 
(sequence of bitmap files, sequence of metafile files or an 
animated gif file).  
Click on Save.  

7. Export a dynamic graph  

Graphe Easy allows you to save a dynamic graph in different graphic file 
formats :  

Load the animated graph.  
Set it.  
Record the settings.  
Click on .  
Select the file format you want to export your animation in 
(sequence of bitmap files, sequence of metafile files or an 
animated gif file).  
Click on Save.  
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